Versions recommandées pour les applications d'exploitation (JCMS 8 / JCMS 9)

Par application d'exploitation on entend : frontal web (Apache), serveur d'application (Tomcat, Websphere), Java/JDK.

Cette page concerne les versions 8 et 9 des plateformes Jalios. ( Voir v.10 )

Pour rappel : les versions majeures des applications d'exploitation recommandées par Jalios sont précisées dans le document d'installation et d'exploitation de chaque version, et nous recommandons de toujours utiliser les dernières releases (correctifs de stabilité et de sécurité) de celles-ci. ( (Lien en accès restreint) , V9 )

Apache : (recommandé Apache 2.2 ou 2.4)

Tomcat : (recommandé Tomcat 7)

  • ̶T̶o̶m̶c̶a̶t̶ ̶5̶ : cette version n'est pas supportée par Jalios
  • Tomcat 6 : version obsolète, nous recommandons de passer à la V7 (à défaut la version 6.0.42 ou supérieure)
  • Tomcat 7 : la version doit être 7.0.55 ou supérieure (divers problèmes constatés notamment sur les versions <42 et sur les versions 53-54)
  • ̶T̶o̶m̶c̶a̶t̶ ̶8̶.̶0̶ : cette version n'est pas certifiée (ni testée) par Jalios (elle est d'ailleurs en fin de vie)
  • Tomcat 8.5 : Validé avec JDK8 pour JCMS 9 SP4. Choisir une version récente (problème connu sur la 8.5.4). Configuration genStringAsCharArray à activer.

Java : (recommandé Oracle JDK 7)

  • JDK 6 : version obsolète, nous recommandons de passer à la V7 (à défaut la toute dernière version)
  • JDK 7 : la version doit être 1.7.60 ou supérieure (divers problèmes constatés dans les versions antérieures)
    • Dernière version publique 1.7.79 (avril 2015), Oracle propose un support 'Premium' avec des mise à jour jusqu'en Juillet 2019
  • JDK 8 : Validé avec Tomcat 8.5 pour JCMS 9 SP4. Choisir une version récente (problèmes rencontrés sur d'anciennes versions <111 ). Remplacer configuration du PermGenSpace par configuration du MetaSpace.
  • ̶O̶p̶e̶n̶J̶D̶K̶ : aucune version n'est certifiée (ni testée) par Jalios
  • ̶J̶a̶v̶a̶ ̶9̶ : non-certifié (ni testée) par Jalios

IBM : Websphere + Java "IBM J9 VM"

  • Avec WAS 7 il faut utiliser la JVM IBM J9 1.6.0 SR11 ou supérieure
  • Pour JCMS 9 nous ne certifions pas WAS 7 mais WAS 8.5.5 (avec la JVM IBM J9 1.7 associée)