Erreur lors du build projet

Seifallah Bellassoued · le 05/11/18 à 17:51

Bonjour,

J'utilise l'environnement JADE version 2.0.3 pour faire le build d'un projet Jplateform 10.

Mon module dépend de 3 autres modules qui sont ajoutés sous artifact/.

Lors du lacement du build, je recois cet erreur

05-Nov-2018 17:42:59 [copyPluginDependencies] Trying to locate locally plugin 'CalendarPlugin' on : /var/data/atlassian/bamboo/6.6.3/xml-data/build-dir/NAN-NAN-JOB1/jcmsartifact
05-Nov-2018 17:43:00 [copyPluginDependencies] Deploying 'CalendarPlugin' plugin to /var/data/atlassian/bamboo/6.6.3/xml-data/build-dir/NAN-NAN-JOB1/build/../work/JCMS/WEB-INF/plugins/CalendarPlugin/plugin.xml
05-Nov-2018 17:43:00 [copyPluginDependencies] Could not load org.apache.xerces.parsers.SAXParser: SAX2 driver class org.apache.xerces.parsers.SAXParser not found: org.apache.xerces.parsers.SAXParser
05-Nov-2018 17:43:00 [copyPluginDependencies] Ignore dependency : 'CalendarPlugin'
05-Nov-2018 17:43:00 [copyPluginDependencies] Trying to locate locally plugin 'DBPollPlugin' on : /var/data/atlassian/bamboo/6.6.3/xml-data/build-dir/NAN-NAN-JOB1/jcmsartifact
05-Nov-2018 17:43:00 [copyPluginDependencies] Deploying 'DBPollPlugin' plugin to /var/data/atlassian/bamboo/6.6.3/xml-data/build-dir/NAN-NAN-JOB1/build/../work/JCMS/WEB-INF/plugins/DBPollPlugin/plugin.xml
05-Nov-2018 17:43:00 [copyPluginDependencies] Could not load org.apache.xerces.parsers.SAXParser: SAX2 driver class org.apache.xerces.parsers.SAXParser not found: org.apache.xerces.parsers.SAXParser
05-Nov-2018 17:43:00 [copyPluginDependencies] Ignore dependency : 'DBPollPlugin'
05-Nov-2018 17:43:00 [copyPluginDependencies] Trying to locate locally plugin 'VirtualDesktopPlugin' on : /var/data/atlassian/bamboo/6.6.3/xml-data/build-dir/NAN-NAN-JOB1/jcmsartifact
05-Nov-2018 17:43:00 [copyPluginDependencies] Deploying 'VirtualDesktopPlugin' plugin to /var/data/atlassian/bamboo/6.6.3/xml-data/build-dir/NAN-NAN-JOB1/build/../work/JCMS/WEB-INF/plugins/VirtualDesktopPlugin/plugin.xml
05-Nov-2018 17:43:00 [copyPluginDependencies] Could not load org.apache.xerces.parsers.SAXParser: SAX2 driver class org.apache.xerces.parsers.SAXParser not found: org.apache.xerces.parsers.SAXParser
05-Nov-2018 17:43:00 [copyPluginDependencies] Ignore dependency : 'VirtualDesktopPlugin'
05-Nov-2018 17:43:00
05-Nov-2018 17:43:00 BUILD FAILED
05-Nov-2018 17:43:00 /var/data/atlassian/bamboo/6.6.3/xml-data/build-dir/NAN-NAN-JOB1/build/buildPlugin.xml:199: The following error occurred while executing this line:
05-Nov-2018 17:43:00 /var/data/atlassian/bamboo/6.6.3/xml-data/build-dir/NAN-NAN-JOB1/build/buildPlugin.xml:358: The following error occurred while executing this line:
05-Nov-2018 17:43:00 /var/data/atlassian/bamboo/6.6.3/xml-data/build-dir/NAN-NAN-JOB1/build/buildPlugin.xml:675: Error in dependency management

Avez vous une idée?

Merci.

#1

Merci pour cette nouvelle conversation.

En cas de nécessité, vous pouvez créer un ticket dans votre espace support en référençant cette conversation.

Cordialement.

Support Jalios · le 13/11/18 à 00:30
12 pts
Ronan Kerdudou - le 15/11/18 à 09:36
Meilleure réponse

Le message semble être : Il manque le driver SAX2.

Vérifiez votre installation, il manque peut être une lib Xerces ou elle est mal déclarée dans le path d'execution.

(voir étape 14 de  (Lien en accès restreint) )

#1

Résolu,

Merci beaucoup  @Ronan Kerdudou .

Seifallah Bellassoued · le 19/11/18 à 11:39
9 pts