We apologize for untranslated text, you can use the Google Translation button to get an automatic translation of the web page in the language of your choice.

Impossible de mettre à jour une instance de jcms via le déploy manager

Benoit Chapel · on 2/7/13 at 2:35 PM

Nous avons un serveur d'intégration avec : une instance JCMS 7.1 d'URID dev1 (http://jcms-dev:8080/jcms71) une instance JCMS 7.1 utilisée en deploy manager (http://jcms-dev:8080/jcms71deploy)

Avec ce deploy manager, nous avons : - téléchargé une copie complète (pinacle_2013-02-07_14-38-51.war) - téléchargé la signature (signature_dev1_2013-02-07_14-39-05.xml)

Nous avons ensuite décompressé la copie de travail sur une machine de développeur. Nous changeons l'URID de cette instance sur la machine de développeur (bch). Nous effectuons des modifications sur cette copie de développement (http://localhost:8080/jcms) Ensuite, on se rend dans l’interface de gestion des changements de cette instance locale (bch). On signe la version locale (bch). On calcul les changements (par rapport à dev1) et il y en a. On enregistre ces changements et on obtient un fichier pinacle_bch_delta_2013-02-07_15-10-49.zip

Lorsqu'on retourne sur le deploy manager (http://jcms-dev:8080/jcms71deploy) et qu'on essaye de mettre à jour (dev1) avec ce fichier zip obtenu, on a le message suivant :


Pour des raisons de sécurité, l'opération demandée n'a pas été effectuée.

Cette requête ne contenait pas les paramètres de sécurité requis. Une personne mal intentionnée vous a peut être dirigé sur cette page à votre insu ou le formulaire que vous avez soumis ne contenait pas les informations de sécurité nécessaires.

Si vous souhaitez vraiment effectuer cette opération, veuillez soumettre le formulaire à nouveau. En cas de doute nous vous recommandons de vous déconnecter du site puis de quitter cette page en fermant votre navigateur..

Cette requête a été enregistrée sous la référence '26790be4164742967309283' si vous souhaitez contacter un administrateur.


Avez vous une idée de ce qui empèche la mise à jour ?

12 pts
Xuan Tuong LE · on 2/7/13 at 3:36 PM

Bonjour,

C'est une anomalie (JCMS-2918) connue concernant la version 7.1.0. Elle est corrigée à partir de 7.1 SP1.

A noter que nous recommadons désormais d'utiliser le nouveau système de déploiement.

Cordialement,

0 pts
Benoit Chapel · on 2/7/13 at 3:51 PM

J'ai oublié de préciser qu'il s'agissait de la 7.1.2 et donc que le problème n'est donc pas réglé.

Après, si vous décidez de ne plus maintenir le déploiement par deploy manager, il faudrait le supprimer de la doc et améliorer le nouveau système qui semble assez "lourd".

0 pts
Xuan Tuong LE · on 2/7/13 at 4:12 PM

Merci de votre précision. Nous allons étudier votre problème.

Je suis surpris de votre remarque sur le nouveau système de déploiement car la plupart de nos clients l'ont exploité avec satisfaction. Quels sont les points qui vous ont empêché d'adopter ce nouveau système ?

0 pts
Benoit Chapel · on 2/7/13 at 4:35 PM

On nous à présenter le nouveau système comme quelque chose d'automatisable (ce qui en soit serait une bonne chose) mais qui nécessite quand même d'intervenir manuellement à plusieurs endroits du process (pour de l'automatisable, c'est gênant)

C'est pour l'instant un à priori qui nous faisait préférer la méthode du deploy manager qui, quitte à intervenir manuellement, nous semblait plus conviviale.

Nous allons nous pencher sur le nouveau système.

0 pts
Xuan Tuong LE · on 2/12/13 at 11:35 AM

Bonjour,

Je reviens vers vous sur ce problème. Je constate effectivement le comportement. En attendant un correctif de notre part (issue JCMS-3402), vous pouvez désactiver le contrôle CSRF sur la webapp Deploy Manager, en positionnant la propriété suivante dans custom.prop :

channel.security.csrf.enabled: false

Merci d'avance.

Sinon, concernant le nouveau système, il a été conçu en scripting pour l'automatisation. N'hésitez pas à revenir vers nous.

0 pts