Membre espace collaboratif sans accès

Paul Morel · le 21/10/16 à 09:12

Bonjour,

J'ai créé un espace co dans lequel j'ai ajouté un groupe User ayant les droits de contribution sur l'ensemble des contenus et les portlet de l'espace co. 

Lorsque je vais sur le profil de l'utilisateur, il est bien inscrit dans les informations techniques que cet utilisateur appartient à l'espace collaboratif en question.

Cependant, lorsque je m'identifie avec cet utilisateur, je ne vois pas l'espace co dans la liste de mes espaces et je ne peut pas accéder à la partie front de l'espace co. J'arrive cependant bien à aller sur la partie back office.

Est-ce qu'il y a une manipulation particulière à faire pour que l'utilisateur puisse accéder au front ? Je n'ai pas trouvé d'espace où je peux activer le "consultation" ou quelque chose dans ce genre.

Merci d'avance,

 

Paul

 

 

16 pts
Ronan Kerdudou - le 27/10/16 à 16:21
Meilleure réponse

Lorsque l'espace co est un espace modèle, il n'est pas utilisable pour travailler, uniquement par les administrateur qui modifient le modèle en vue de créer de vrais espaces collaboratifs.

8 pts
Ronan Kerdudou · le 25/10/16 à 18:05

Le comportement que vous décrivez est étrange, je ne vois pas comment c'est possible. Pouvez vous indiquer plus de détails sur votre configuration ? Est-il possible qu'un développement spécifique sur votre plateforme provoque cet effet ?

0 pt
Paul Morel · le 26/10/16 à 14:45

Bonjour,

Merci de votre réponse. 

Non il n'y a aucun développement spécifique, je suis parti d'un devpack standard de JCMS 9 SP3.

J'ai finalement trouvé une partie de la solution en modifiant les droits d'accès à la portlet Espace collaboratif et mes membres peuvent dorénavant consulter la partie front de l'EC. Néanmoins, cet espace co ne figure toujours pas dans la liste de leurs EC de la portlet Mes Espaces Co.

#1

êtes vous bien sûr qu'il sont membres d'un groupes de l'espace concerné ?

Pouvez-vous aussi vérifier si de puis le FO de l'espace co, dans la liste des membres de l'espace vous les retrouvez bien présents ?

Ronan Kerdudou · le 26/10/16 à 14:52
#2

Notez aussi que vous pouvez tester (en tant qu'admin central) les droits d'accès à une portlet pour un membre donné via la fonction d'audit. Vous saurez ainsi pour quelle raison il ne la voit pas, ça pourrait expliquer le problème que vous rencontrez.

Notez aussi que la portlet espace collaboratif ne devrait jamais être modifiée directement, il vaut mieux toujours passer par l'ihm dédiée aux espace co et considérer cette portlet comme un élément technique réservé.

Ronan Kerdudou · le 26/10/16 à 14:58
#3

Mes membres ont bien accès à l'espace collaboratif, ils ne le voient simplement pas dans la portlet "Mes espaces collaboratifs"

Paul Morel · le 26/10/16 à 15:07
0 pt
Paul Morel · le 26/10/16 à 14:53

Oui ils sont bien dans la liste de mes membres affichés en front

0 pt
Paul Morel · le 26/10/16 à 15:06

Lorsque je teste les droits d'accès de mes membres à la portlet via l'audit, il m'indique que tous les droits sont ok.

J'ai simplement ajouté des groupes de consultation à la portlet, comment faut-il modifier cela ?

#7

ah ! c'est un espace modèle !

Effectivement la notion de "modèle" est un paramètre de l'espace, il ne peut pas être utilisé, il sert de modèle.

Ronan Kerdudou · le 26/10/16 à 18:28
#8

Concernant la licence, vous devriez avoir accès à une clef de développement.

Ronan Kerdudou · le 27/10/16 à 16:22
#9

J'ai bien intégrer ma clé, tout fonctionne correctement désormais. Merci

Paul Morel · le 28/10/16 à 11:51
0 pt
Paul Morel · le 27/10/16 à 16:22

Merci pour vos retours. J'ai donc récupérer un clé add-pack je vais tester en créant un espace co à partir de mon modèle.

0 pt